So guys,

I came across this error log while trying to run OpenVPN in Ubuntu 16.04.

AUTH_FAILED,Google Authenticator Code must be a number

I had installed OpenVPN from repo and had two factor authentication enabled. If you are getting the same issue, then follow these steps in order to fix the issue. Solution is to install OpenVPN from source. These are the steps. Enjoy!!!

  1. First download OpenVPN from here: https://swupdate.openvpn.org/community/releases/openvpn-2.3.11.tar.gz
  2. Extract the file to required location with this command: tar -xvf <file_name>
  3. Go inside the OpenVPN directory and run the command:     ./configure && make && make-install
  4. Navigate to the directory <open_vpn_main>/src/openvpn and run openvpn executable from this location and run command sudo ./openvpn –config client.ovpn

you can set symbolic link if you want to run it from any location. Just run this command

sudo ln -s <path_to_openvpn_executable> /usr/bin/openvpn


 

Advertisements